This error happens when setting chart.type or series.type to a series type that isn't defined in Highcharts. A typical reason may be that the module or extension where the series type is defined isn't included.


For example in order to create an arearange series, the highcharts-more.js file must be loaded.


The safest way to check which files are required to avoid this type of error is to open a pure JavaScript demo of the series type you will be using and check which files are loaded in the HTML section of the demo (in case of JSFiddle).


Demos:


Another good way is to check documentation for the series you are going to use. 


In the end, make sure you have not made a typo when setting the series type either in chart.type or in series.type, because the error will look the same in this case.


In case you cannot find a demo for the series you want to use and there's no information about required files in the documentation please let us know about this problem, so we could improve our demos and docs, by opening an issue on main Highcharts GitHub repository.